Railsを勉強中。やはりEmcsで編集したいので、Rinariを導入してみる

ELPAの試しと失敗

  • ELPAからのインストールがおすすめらいいので、まずはELPAを導入
  • auto-installを使ってELPAをインストール(ややこしいな)
  • 今までは、起動が遅くなる為、auto-install-update-emacswiki-package-nameをコメントアウトしてるので、まずは復活する
  • auto-install-update-emacswiki-package-nameを実行
  • M-x install-elisepでインストールを起動
  • URLが聞かれるが、なんか[http://bit.ly/pkg-el23](http://bit.ly/pkg-el23)rejectされるので、直接に展開後の長いURLを入力して実行した
  • init.elに必要な設定を追加

    ;; package.el (when (require ‘package nil t) (add-to-list ‘package-archives ‘(“marmalade” . “http://marmalade-repo.org/packages/”)) (add-to-list ‘package-archives ‘(“ELPA” . “http://tromey.com/elpa/”)) (package-initialize))

Rinariをインストール

  • ELPAは初回実行なので、list-packageを実行する
  • Cannot open load file: ruby-compilatioエラーで落ちた
  • 原因はよく分からないので、とりあえずはやめた

直接インストール

  • 基本は、Basic-Setupを参照する
  • submoduleを利用するので、
    • git submodule add git://github.com/eschulte/rinari.git .emacs.d/elisp/rinariを実行
  • rhtml-moderinariのものを使う
    • git submodule add https://github.com/eschulte/rhtml.git .emacs.d/elisp/rhtml

これで、ビューファイルを開くと、rhtml-modeになって、rinariも有効になるはず